Suggestion: Rename ViewModelBase to PropertyChangedBase

Jul 17, 2009 at 10:05 PM

The ViewModelBase class, at present, is just a nice implementation of the INotifyPropertyChanged interface. 

This is useful in places other than ViewModel.  Some Model classes can use it where the View directly binds to the model for simple display of output-only values that don't need any transformation by the ViewModel, or, for example, are bool that control visibility, etc.

I propose renaming the class to be PropertyChangedBase to reflect its wider applicability.

Matt

Coordinator
Jul 18, 2009 at 12:48 AM

Great suggestion, Matt.  I renamed ViewModelBase to ObservableObject.  

Thanks,

Josh